Symptom
Apply button is not available to apply the eligibility rules.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Reproducing the Issue
Go to the compensation template > Plan Setup > Plan Details dropdown > Eligibility. Notice the apply button is not highlighted to apply the eligibility rules.
Cause
There are one or more eligibility rules deleted from the system that were previously mapped to the compensation template. The rules can be identified by the tag (Not in the system).
Resolution
Unlink the eligibility rules from the compensation template or create a new eligibility rule with the same name as the deleted rule. Then, the apply button will appear highlighted.
Keywords
unable to apply eligibility rules, sf, success factors , KBA , LOD-SF-CMP , Compensation Management , Problem
SAP Knowledge Base Article - Public