SAP Knowledge Base Article - Public

2876477 - Billing Plan Value Field Grayed Out in Adaptation Mode for Service Contracts

Symptom

You notice that the Billing Plan related fields and tab are grayed out in Adaptation Mode when trying to add them in a Service Contract

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Contracts work center.
  2. Open any existing service contract.
  3. Navigate to the user options.
  4. Click Start Adaptation Mode.
  5. Click to Edit for items pane of the contracts.
  6. See that the Billing Plan fields are grayed out, even though they can be set as visible, they are not going to be displayed.

Cause

The Billing Plan Fields and Tab are only visible if the Integration of Contract with external system is scoped, since these fields are replicated from ERP/S/4.

Resolution

To scope the Integration of Contract with External System, follow the steps below:

  1. Navigate to Business Configuration work center.
  2. Navigate to Implementation Projects work center view.
  3. Select the Initial Implementation project.
  4. Click Edit Project Scope.
  5. Navigate to step 3 "Scoping".
  6. Expand the option "Communication and Information Exchange"
  7. Expand the option "Integration with External Applications and Solutions"
  8. Scroll down until you find the option "Integration into Sales, Service and Marketing Processes".
  9. Scope this element.
  10. Save the changes.

Please notice that once the Contract Integration is scoped, it will only work for new contracts.

Keywords

Contract; Service Contract; C4C; Billing Plan Value; Billing Plan; Fields; Fields Grayed Out; Adaptation Mode; Service; Communication and Information Exchange; Integration with External Applications and Solutions; Integration into Sales, Service and Marketing Processes; , KBA , LOD-LE-COP , Contract Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions