Symptom
You notice that the Billing Plan related fields and tab are grayed out in Adaptation Mode when trying to add them in a Service Contract
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Contracts work center.
- Open any existing service contract.
- Navigate to the user options.
- Click Start Adaptation Mode.
- Click to Edit for items pane of the contracts.
- See that the Billing Plan fields are grayed out, even though they can be set as visible, they are not going to be displayed.
Cause
The Billing Plan Fields and Tab are only visible if the Integration of Contract with external system is scoped, since these fields are replicated from ERP/S/4.
Resolution
To scope the Integration of Contract with External System, follow the steps below:
- Navigate to Business Configuration work center.
- Navigate to Implementation Projects work center view.
- Select the Initial Implementation project.
- Click Edit Project Scope.
- Navigate to step 3 "Scoping".
- Expand the option "Communication and Information Exchange"
- Expand the option "Integration with External Applications and Solutions"
- Scroll down until you find the option "Integration into Sales, Service and Marketing Processes".
- Scope this element.
- Save the changes.
Please notice that once the Contract Integration is scoped, it will only work for new contracts.
Keywords
Contract; Service Contract; C4C; Billing Plan Value; Billing Plan; Fields; Fields Grayed Out; Adaptation Mode; Service; Communication and Information Exchange; Integration with External Applications and Solutions; Integration into Sales, Service and Marketing Processes; , KBA , LOD-LE-COP , Contract Processing , How To