SAP Knowledge Base Article - Public

2877375 - Custom token in the Requisition Posted Email Trigger does not work - Recruiting Management

Symptom

Custom token added in an email template linked to the email trigger "Requisition Posted" does not populate any values in the received email.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

1. Create a new email template in Manage Recruiting Email Templates.

2. Add custom token (example: JOB_REQUISITION_CUSTOM1).

3. Recruiting Email Triggers: select the newly created email template to the trigger "Requisition Posted" enable it.

4. Post a Job Requisition (internal, external, internal private, external private, agency/agencies, eQuest).

5. The email received by the defined recipients shows the custom token (example: JOB_REQUISITION_CUSTOM1) instead of a value. The token does not populate any values in the received email.

Cause

One of the possible causes could be that the custom token (example: JOB_REQUISITION_CUSTOM1) is not supported for this specific email trigger "Requisition Posted".

Resolution

You would need to select only those tokens that are supported. Click on "Add supported tokens" to view the list of supported tokens. You can also refer to the "Supported Tokens" section in the trigger "Requisition Posted" to check which tokens it supports.

Keywords

Custom Token, Requisition Posted, Email Trigger , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting 1908