SAP Knowledge Base Article - Public

2877411 - Some CC Role Types receive the Custom Workflow Notifications while others receive the Standard Workflow Notifications

Symptom

Why do some CC Role Types receive the Custom Workflow Notifications while some receive the Standard Workflow Notifications?

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors Employee Central - Workflows
  • SAP SuccessFactors Employee Central - Document Generation

Cause

The DEFAULT_LOCALE of the CC Role is not maintained in any templates within the Document Generation Group. For example, if the CC Role's DEFAULT_LOCALE is Korean and the Document Generation Group (Email Template Group) assigned in the Workflow does not have any templates in Korean, the CC Role will receive the Standard Workflow Notification.

Or

Group "Document Generation Group" is Missing in Document Generation template.

Or

No placeholders present in document template.

Or

The user triggering the notification does not have permission to Document Generation.

Resolution

  • If the CC Role Type's DEFAULT_LOCALE is maintained in the Templates within the Document Generation Group, the Workflow Email Notification will be sent in this locale. If it is not maintained, the Standard Workflow Notification will be used.
  • If the CC Role Type is External Email, the locale of last approver will be used, if no approvers and only cc then en_US locale will be used (hardcoded). If templates in matching locale is maintained within the Document Generation Group, the Workflow Email Notification will be sent in this locale. If it is not maintained, the Standard Workflow Notification will be used.
  • If no placeholders present in template, then put a placeholder to in template to put values like name, document name or any text value onto template so that custom email would be sent out and not missed.
  • Make sure that the user has related permissions under "Manage Document Generation" table in RBP. The permissions available here are: Manage Document Template, Manage Document Template Mapping, Generate All Documents as Admin, Mass generate all documents as an admin.

To avoid any unexpected behavior, make sure to maintain all the available Languages in the Instance within the Document Generation Template and assign them in the same Document Generation Group.

Guide: Employee Central Workflows: Implementation and Administration

Chapter : Creating Custom Templates with Document Generation

Guide : Employee Central Document Generation

Chapter : Document Generation and workflow

See Also

  • 2347226 - Employee Central - Document Generation 
  • 2699796 - How to check the users who received a mass generated document 
  • 2287616 - List of supported tags for EC Workflows and EC Alerts
  • 2295288 - Document Generation: Specific employees are unable to see the "Document Generation" related tools in Admin Center

Keywords

Default Locale, CC Role, Custom Email Notifications, Custom Workflow Nofitications, Email Template Group, Standard Workflow Notifications, Document Generation, Language, Workflow Email Notifications, External Email, CC Role Type, Incorrect Workflow Template, Document Generation Template, Locale , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC-DOC , Document Generation , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions