Symptom
You are replicating Business Partners from SAP ECC/S4 with Sales Area dependent Partner Functions, inbound Web-Service Message is successful, yet the corresponding Partner Function(s) is not updated in the Account.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Login to Cloud for Customer system.
- Go to Administrator workcenter, General Settings View.
- Open Webservice Message Monitoring view.
- Find and check Business Partner replication inbound message, e.g. Service BusinessPartnerERPReplicationIn or BusinessPartnerReplicationIn.
- Ensure Status is Successful.
- Check the Payload, ensure relevant PartnerFunction nodes exist in the payload under corresponding SalesArrangement node.
- Now go to Customers workcenter, Accounts view.
- Find and open the Account.
- Check the Facet Relationships or Account Team.
- Partner Functions are not updated here.
Cause
This could happen because of three possible causes as explained below,
- This is a self-reflexive Partner Function, where the relationship is between the Account itself.
- There is no BusinessPartnerRelationshipCatagoryCode or PartyRoleCode sent under the corresponding PartnerFunction node in the payload.
- Corresponding local Relationship(s) or Party Role(s) are not set as "Sales Area" dependent in Cloud for Customer.
Resolution
Go through below resolutions for above mentioned causes,
- Self-Reflexive partner functions are not supported in Cloud for Customer. Cloud for Customer system has a built-in mechanism of determining Account itself as Ship-To/Bill-To etc. in transactional documents, if there are no specific Ship-To/Bill-To etc. relationships are not maintained for the Account.
- If there are no BusinessPartnerRelationshipCatagoryCode or PartyRoleCode sent under the corresponding PartnerFunction node, then system would not understand which "Account Team Role" or "Relationship" to be added to the Account, hence the inbound message would processed and such PartnerFunctions would just be ignored.
- If the PartnerFunction node has all relevant information and you also have also maintained code list mappings for the corresponding BusinessPartnerRelationshipCategoryCode &(or) PartyRoleCode, yet they are not updated in the Account, then you need to ensure those local BusinessPartnerRelationshipCategoryCode &(or) PartyRoleCode are set as Sales Area Dependent.
- Relationships
- Go to Business Configuration workcenter.
- Open relevant Implementation Project.
- Find and open fine-tuning activity General Business Partners.
- Click on Maintain Relationships.
- Search the relevant local relationship(as per the code list mappings maintained for external BusinessPartnerRelationshipCategoryCode).
- Select the checkbox "Sales Area Dependency".
- Account Team
- Go to Business Configuration workcenter.
- Open relevant Implementation Project.
- Find and open fine-tuning activity Party Role Definition.
- Search the relevant local Party Role code(as per the code list mappings maintained for external PartyRoleCode).
- Select the checkbox "Sales Data".
- Once you have performed all required configurations, trigger a new business partner replication from SAP ECC/S4H.
Additional Note - Enable UI Columns for Sales Data in Account>>Account Team & Relationships facet, so that users can see the associated sales area for account team role and relationships.
See Also
Keywords
KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , LO-INT-COD , CRM On Demand Integration , Problem