Symptom
You are using a placeholder for the 'Completion Due' field in an e-mail template. When you send e-mails via ticket interactione, UTC time zone is displayed instead of the recipient’s time zone.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: You have created an email template ABC, which is using a placeholder for field 'Completion Due'. (ABC represents for the email template name)
- Go to the Service work center.
- Go to the Tickets work center view.
- Open a ticket and go to Interactions facet, send out an email here using the email template ABC. You are expecting that the time zone of field 'Completion Due' is picked based on the recipient's time zone setting in this email. ( the time zone in "My Settings" of the recipient). However, you find the placeholder is showing as UTC time zone.
Cause
In case of interactions and the usage of templates, the recipient might not be the business partner in the system. The template might get selected before entering the recipient as well. Also there can be multiple recipients with different time zone settings. Hence converting the date time to a certain time zone is not possible.
To avoid such issues, we keep the data time as standard in UTC.
Resolution
This is the system standard design.
See Also
PS:
This design in email template is different than workflow rule placeholder currently. For workflow rule, there is a logic to determine the date time format which to be sent out in the email, and it is dependent on the recipient who is the business partner in the system.
It looks for the time zone from:
- The basic settings of the recipient.
- Else in the communication data.
- Then the date time format maintained in the workflow rule.
If none of these three logics suffice, workflow e-mail will send the date/time in UTC.
Keywords
Placeholder;Completion Due;E-mail Template;UTC Time Zone; , KBA , LOD-CRM-SRP , Service Request Processing , How To