Symptom
The following behavior occurs in SAP Analytics Cloud (SAC):
-
When applying Chart Scaling for measures used in charts, measures are scaled equally unless the chart is not set to Full-screen.
-
When in full-screen view of the chart it displays the following warning message:
"Scaling is not being applied to this chart because the chart is in full screen mode" -
When going in full screen mode for a chart, the results are confusing to users as axes suddenly differ. If chart details are hidden, the warning icon with message “scaling is not supported in full screen mode” is not even visible.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Analytics Cloud
Reproducing the Issue
- Create a Story with any BestRunJuice_SampleModel model and place a Combination Column & Line chart
-
Configure the chart as shown below
- Apply the Chart scaling for the 2 measures Discount and Gross Margin and click on Done.
(Observe both the Y-Axis values are scaled and this is the correct behavoir of the chart) - Click on the Fullscreen button.
-
Observe the Chart scaling is automatically removed and both Y-Axis values are not scaled and displays different values. And a warning message is displayed. Refer below image.
(The logic expectation is that it should behave like the Chart of Step 3. i.e. Even in Fullscreen the Chart Scaling should be taken into action.)
Cause
Fullscreening a chart by itself is developed and designed to visualise the chart in its most optimal way. Chart-scaling is disabled in full screen mode in order to prevent the data points from unnecessarily scale by a measure that is not displayed to the user. This is a by design behaviour.
Resolution
- There is already a request open for enabling Chart Scaling in Fullscreen: Customer Influence Request ID 232294: Enable Chart Scaling in full screen mode
- For more information about enhancement ideas for the SAP Analytics Cloud product that you would like to share with product management and/or other customers:
KBA 2424376 - How to create an enhancement request for SAP Analytics Cloud?
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- SAP Analytics Cloud > Learning > Guided Playlists
- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
- Need More Help? Contact Support or visit the solution finder today!
Your feedback is important to help us improve our knowledge base.
Keywords
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC , KBA , LOD-ANA-DES , Story Design & Visualizations , LOD-ANA-BI , Business Intelligence Functionality, Analytic Models , Problem