SAP Knowledge Base Article - Public

2878338 - Existing emergency contact information purged when performing incremental load

Symptom

Existing emergency contact record for a user is purged when a new record with same relationship type is imported through incremental load.

Environment

  • SAP SuccessFactor HXM Suite
  • SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Login to instance
  2. Go to import employee data
  3. Download Emergency contact template
  4. Fill in the details. Make sure you are using same relationship type (example, parent) as the existing record. Primary flag=N
  5. Perform incremental import
  6. Notice existing data is removed 

Cause

As per current system design, there is no qualifier to differentiate between update or insert when performing Emergency Contact incremental load for same relationship type.

Emergency contact import does not support incremental load, full purge must be used. So unless all existing records are included in the import file, there is no way of retaining existing data.

It's not possible to delete/delimit emergency contact through import, as Compound Delete is not possible for hris-element emergencyContactPrimary.

Resolution

  • Provide all the records (new and existing) of same relationship type in the import template during incremental import.
  • Enhacement request: ECT-129570, to change system behavior is raised. Kindly get in touch with your CSM to know the status of the enhancement request

Keywords

Emergency contact, emergency contact incremental import, existing emergency contact deleted, old record purged, incremental load, contact information purged, incorrect incremental load behavior , KBA , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , Product Enhancement

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core all versions