SAP Knowledge Base Article - Public

2879507 - When Entering Phone Number to Business Partner, System Adds "EXT" at the End of the Phone Number

Symptom

When entering a phone number that contains more than 10 digits to a business partner, the system adds "EXT" automatically and formats the number like this XXXXX XXXXX EXT XX (where each X is a digit).

Environment

SAP Cloud for Customer

Reproducing the Issue

If the business partner is an individual customer, please reproduce the issue as follows. If it is not an individual customer, you might need to reproduce the issue in the Account or Contact view.

  1. Go to Customer work center
  2. Click on Individual Customer view
  3. Click on the pencel icon to edit it
  4. Enter the phone number
  5. Click on Save

Cause

This only applies for phone numbers that belong to the NANPA (North American Numbering Plan).

NANPA consists of the United States, Canada, and other countries primarily in North America. They all share the international dialing code +1.

NANPA phone numbers follow a very rigid structure. If the number has more than ten digits, everything after the tenth digit is considered an extension.

Resolution

The system behaviour is correct. Unfortunately, this cannot be customized.

See Also

SAP Cloud for Customer Phone Number Parsing and Formatting

Keywords

ext automatically added to phone number, suppress automatic addition, business partner, individual customer, account, ext added again, , KBA , LOD-LE-BP-BP , Business Partner , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions