SAP Knowledge Base Article - Public

2880426 - Business Partner Integration between C4C & SAP S/4HANA Cloud Public Edition creates the Business Partner with a different number

Symptom

During Business Partner integration between C4C and SAP S/4HANA Cloud Public Edition the Business Partner is created in SAP S/4HANA Cloud Public Edition with a different number than it has in C4C.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. A Business Partner is replicated from C4C to SAP S/4HANA Cloud Public Edition.
  2. The replicated Business Partner is created in SAP S/4HANA Cloud Public Edition with a different number than in C4C.

Cause

  • A BP Grouping with an Internal Number Range has been used in the <NumberRangeIntervalBusinessPartnerGroupCode> tag.
  • This behaviour can also occur if the <NumberRangeIntervalBusinessPartnerGroupCode> tag is missing, in which case the system will default to internal numbering even if a value is passed in the <InternalID> tag. 

Resolution

  1. Ensure that the <NumberRangeIntervalBusinessPartnerGroupCode> tag is sent in the payload.
  2. Use a BP Grouping with an external number range in the <NumberRangeIntervalBusinessPartnerGroupCode> tag.

Keywords

NumberRangeIntervalBusinessPartnerGroupCode, InternalID, C4C, Internal Numbering, Internal Number, External Number, External Numbering, SAP S/4HANA Cloud Public Edition, S4_PC, S/4HC, BP, Business Partner, Business, Partner, , KBA , LO-MD-BP , Business Partners , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions