SAP Knowledge Base Article - Public

2880974 - Workflow Rule to Send Notifications Is Not Working

Symptom

You have created a Workflow Rule to send notifications but when the conditions are met, the respective user does not see the notification.

Environment

SAP Cloud for Customer

Reproducing the Issue

For the example's purpose, let's say you have Workflow Rule ABC (ABC represents the Name of the Workflow) that triggers a notification to Employee ID 123 (123 represents the Employee ID).

When the conditions are met, Employee ID 123 cannot see the notification.

Cause

You did not chose the option to send Push Notifications on the Workflow Rule ABC.

Resolution

If the Push Notification is not turned on, the notifications are sent, but the Employee/User needs to click the Notification Icon (top right corner) to see them.

To turn the Push Notification on:

  1. Go to the Administrator work center.
  2. Select the Workflow Rules view.
  3. Open Workflow Rule ABC.
  4. Enter Edit Mode.
  5. Go to the Step 3: Define Actions.
  6. Click the Push Notification option.
  7. Go to the Step 4: Review.
  8. Click Finish.

Once this is done, the next occurrences of the Workflow Rule will trigger the notification with the red bubble on the notification's icon.

Keywords

Notification ; Workflow Rule ; Push ; Not seen ; Not working ; Workflow Notification ; , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions