SAP Knowledge Base Article - Public

2882132 - Quick Apply Fields Displayed in Wrong Language/Locale - Recruiting Management

Symptom

When candidates apply for a job using Quick Apply, the application fields are not displayed in the candidate’s selected language. Instead, the field labels appear in an incorrect or default language/locale.

Environment

SAP SuccessFactors Recruiting Management

Cause

The job requisition is not posted in the candidate’s locale. As a result, when candidates apply using Quick Apply, the application fields are displayed in the job requisition’s default language rather than the candidate’s selected language.

Resolution

To ensure that application fields translate in the candidate’s language or in one of the supported languages configured in the instance, the corresponding language must be manually added to the job requisition.

Please follow the steps below:

  1. Navigate to Recruiting.

  2. Search for and select the job requisition the candidate is applying for.

  3. Open the Job Requisition Details page.

  4. Locate the Posting Language field.

  5. Add the required languages in which the job should be posted.

  6. Save the changes.

Once the job requisition is posted in the candidate’s language, the application fields in Quick Apply will be displayed accordingly.

See Also

 2859372 - How to enable Quick Apply - Recruiting Management

Keywords

quick apply, fields, translation, field label, quick apply fields, quick apply fields not translating, locale. , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem

Product

SAP SuccessFactors Recruiting all versions