SAP Knowledge Base Article - Public

2882207 - Error- "Incorrect Count Of Node FILE_CONTENT: 0; Must Be Exactly 1"

Symptom

On editing a ticket say changing the ticket status or sending an interaction email, the following standard error is triggered,"Incorrect count of node FILE_CONTENT: 0; must be exactly 1."

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service Work Center.
  2. Then to Tickets View.
  3. Open any Ticket ID XYZ, where, XYZ is any Ticket ID.
  4. Edit the status to a new status.
  5. Error - "Incorrect count of node FILE_CONTENT: 0; must be exactly 1" is triggered.

The error could be triggered on different actions on Ticket as well.

Cause

The error is triggered if  the ticket has an attachment file but no content within it.

Resolution

Please find this file within the Attachment Facet of affected Ticket TI and delete in order for you to continue with normal ticket edit scenarios.

Keywords

Incorrect count of node FILE_CONTENT: 0; must be exactly 1, attachment , KBA , incorrect count of node file_content: 0; , attachment file , ticket , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions