Symptom
On editing a ticket say changing the ticket status or sending an interaction email, the following standard error is triggered,"Incorrect count of node FILE_CONTENT: 0; must be exactly 1."
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to Service Work Center.
- Then to Tickets View.
- Open any Ticket ID XYZ, where, XYZ is any Ticket ID.
- Edit the status to a new status.
- Error - "Incorrect count of node FILE_CONTENT: 0; must be exactly 1" is triggered.
The error could be triggered on different actions on Ticket as well.
Cause
The error is triggered if the ticket has an attachment file but no content within it.
Resolution
Please find this file within the Attachment Facet of affected Ticket TI and delete in order for you to continue with normal ticket edit scenarios.
Keywords
Incorrect count of node FILE_CONTENT: 0; must be exactly 1, attachment , KBA , incorrect count of node file_content: 0; , attachment file , ticket , LOD-CRM-SRP , Service Request Processing , Problem