Symptom
You are trying to maintain an employee as an additional direct approver for Service Confirmations but the employee is not listed in the selection.
or
An approval task for a Service Confirmation cannot be assigned by the system to the expected responsible as per the approval process.
Environment
SAP Business Bydesign
Reproducing the Issue
- Go to the Application and User Management work center.
- Go to the Approval Process view.
- Select the approval process for Service Confirmations.
- Once the screen opens, press the Copy button.
- Select the Work Distribution as Direct Approvers and press the Edit button.
- Employee ABC is not visible.
- Go to the Application and User Management work center.
- Go to Business Task Management View.
- Check the approval task for Service Confirmation.
- You can see that the task is not assigned to the expected user.
Cause
The Work Center / View ID MMA_CUSTOMERSERVICE from WoC MMA_MANAGINGMYAREA is not assigned to User.
Resolution
To resolve this issue follow below steps.
- Go to Application and User Management work center.
- Select the User and Access Management view.
- Select the Business Users subview.
- Choose the Business Users for whom this Service Confirmation Approval Tasks are not getting assigned.
- Choose the Edit button and the Access Rights option.
- Choose MMA_MANAGINGMYAREA expand .
- Select MMA_CUSTOMERSERVICE and enable the check box.
Once the above steps are performed, the system will assign the business task to the expected user or you can enter this user as direct approver while defining the approval process for service confirmation.
See Also
Keywords
MMA_CUSTOMERSERVICE; CRM_SC_APPROVE; Service confirmation approval; , KBA , mma_customerservice , crm_sc_approve , service confirmation approval , SRD-CRM-ORD , Orders & Contracts , Problem