Symptom
You have created a UI adaptation setting (e.g a mandatory field). The mandatory field works correct within the Ticket (Ticket TI). However, when performing changes in the Ticket List outside the Ticket (Ticket OWL), the adaptation setting is being ignored.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Service work center.
- Select the Tickets view.
- In the Ticket OWL click to Set the Ticket to Complete Status.
- Save the changes, the Ticket has been set to Completed even if the Mandatory fields were not fulfilled.
Cause
UI adaptation settings are applicable by standard only at UI level. These capabilities are controlled by UI adaptation framework and the Ticket application cannot control them.
Resolution
For the UI adaptation settings, including mandatory fields, to be checked in the OWL a custom PDI solution must be created from customer side. PDI solutions can validate the data across UIs and across all clients like API, PDI, UI.
There are multiple actions that can be triggered to each BO (e.g After_Modify and Before_Save) which can be used for such implementation.
Keywords
OWL; Adaptation; Ticket; Mandatory; , KBA , LOD-CRM-SRP , Service Request Processing , How To