SAP Knowledge Base Article - Public

2884212 - Business User Access Restrictions Not Working as Expected

Symptom

You noticed that a certain business user in the system has access to data which should not be visible to them based on their access restrictions.

Environment

  • SAP Cloud for Customer
  • SAP Business ByDesign

Cause

This issue may be caused by the fact that the business user (or the business role assigned to this business user) has one or more views from the PDI_PARTNER_DEVELOPMENT work center assigned.

PDI developers need unrestricted read and write access to the system. Therefore, the views from the PDI_PARTNER_DEVELOPMENT work center, when assigned, override any read or write access restriction set for other work centers.

Resolution

To solve this issue, please remove the PDI_PARTNER_DEVELOPMENT work center views (or the business role with these views assigned) from this user's access rights.

If this person will need to perform PDI development work, kindly consider creating a separate business user to be used specifically for this purpose, which can then be assigned to the PDI work center views or the relevant business role that has these views.

Keywords

write access, edit, restrictions, read access, access rights, restriction, work center, settings, PDI , KBA , SRD-CC-IAM , Identity & Access Management , How To

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions