Symptom
You see the below error when publishing your Custom Business Object:
"Publish not possible. Create an incident with component AP-RC-CU-BO"
Environment
- SAP Cloud for Customer
Reproducing the Issue
Pre-requisites:
- You have created a Custom Business Object in the Custom Object Builder.
Steps to reproduce:
- Go to View General Settings under Administrator Work Center.
- Open Custom Object Builder.
- Open your Custom Business Object.
- Click Publish.
Cause
Case 1:
Your user does not have the correct Authorisation to publish a Custom Business Object.
Case 2:
This is a production tenant.
Case 3:
Your user is logged into the system with a language besides English.
Resolution
Case 1:
Make sure that you are performing this action with a development user with administration authorisation:
- Go to View Business Users under Administrator Work Center.
- Search for your user.
- Click Edit and select Access Rights.
- Select tab Work Center and View Assignment.
- Under Work Center PDI_PARTNER_DEVELOPMENT, make sure View IDs PDI_DEVELOPMENT and PDI_ADMINISTRATION are assigned to your user.
Case 2:
The status of the business object in production tenant is Uploaded and Active and so the publish of this custom object is not required. In a future release we will remove the Publish button from production tenants. Currently you can ignore it.
Case 3:
As with all custom development, creating/publishing objects is only supported through English. The user needs to delete the object and create a new one to publish it.
Keywords
PDI, PDI_DEVELOPMENT, PDI_ADMINISTRATION, PDI_PARTNER_DEVELOPMENT, authorization, Custom Object Builder, KUT, Solution, Key User, production, language, english , KBA , AP-RC-CU-BO , Key User Custom Object Generation , Problem