SAP Knowledge Base Article - Public

2884661 - Attachments are not getting replicated from CRM to C4C for Business Activity

Symptom

Attachments are not getting replicated from CRM to C4C for Business Activity and ActivityReplicationIn message fails with below error

Document XYZ already exist

Environment

 SAP Cloud For Customer

Reproducing the Issue

  1. Login to Cloud for Customer.
  2. Go to Administrator workcenter.
  3. Go to General Settings view.
  4. Open Web Service Message Monitoring view.
  5. Find and open failed message with the same error

Cause

In CRM one can add different attachments with the same name and maximum lenght of 40 characters. However, this is not the case in C4C. Same name is not accepted in C4C.

 In the given payload example, there will be multipleattachments with the same name.

Resolution

This is a known integration limitaiton and you should give different names for that attachments of one business activity.

Keywords

Activity Replication, Attachment Replication, CRM , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem

Product

SAP Cloud for Customer core applications all versions