SAP Knowledge Base Article - Public

2884961 - Data Source Appointment Involved Parties Shows Parties with Not Assigned Appointments

Symptom

When reporting on data source Appointment Involved Parties, several lines with Not Assigned (#) values are displayed under Activity related columns, like "Activity Appointment", "Activity Type", and "Activity Category".

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Business Analytics work center.
  2. Go to the Design Data Sources work center view.
  3. Find and open data source Appointment Involved Parties [CODAPAPTYB] in "Preview" mode.
  4. Run the data source by adding the relevant characteristic fields.
  5. The Activity related columns, like "Activity Appointment", "Activity Type", and "Activity Category" are displaying several Not Assigned (#) records.

Cause

This is the expected behavior. The data source Appointment Involved Parties is designed to display the list of all the parties with or without appointments/activities.

Resolution

To remove the Not Assigned entries, filters can be applied in the report selection for the relevant fields (for example, Activity Category) to remove the undesired Not Assigned entries, hence displaying only lines with Activities information.

Keywords

Appointment Involved Parties; Data Source wrong; wrong values in data source; Not Assigned; , KBA , appointment involved parties , not assigned (#) , LOD-CRM-ACT , Activities , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions