Symptom
- The rating labels have been changed in Performance Rating Scale but the launched forms are still showing the previous rating values
- Adhoc/Table/Dashboard/Tiles report is still showing up the previous rating labels for launched forms
- New Performance forms (launched after changing the ratings) are displaying the right labels
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Go to Rating Scales
- Change the label of one rating
- e.g. change the label of the Score 5 from "Extraordinary" to "5 - Extraordinary"
- Launch a new Performance form for an user
- Finish the form with the rating 5
- Run an Adhoc report of Performance Management domain
- Check that all the forms launched prior to changing the rating scale are still showing the previous label i.g. Extraordinary
- Only the new form is showing the updated label i.g. 5 - Extraordinary
Cause
- Changes in Rating Scales will work only for new forms (launched after the change)
- Launched forms will still use the previous configuration of the ratings
- As Adhoc/Table/Dashboard/Detailed Reporting (Live Data reports) pulls the information from the forms, the modified ratings will display only for new forms as well
Resolution
This is an expected behavior in Performance forms and in reports.
Keywords
rating labels changed change Performance Scale live launched forms form Adhoc Table report , KBA , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , How To
Product
SAP SuccessFactors HCM Suite all versions