SAP Knowledge Base Article - Public

2885931 - Ticket Subject Field Not Mandatory in Detail View

Symptom

When creating a Ticket in Detail View, the Subject field is not mandatory.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Select the Tickets view.
  3. Click on the '+' for New.
  4. Click on Save.
  5. The Ticket is saved even though the Subject was not maintained.

Cause

In the Quick Create view, if you choose to close the ticket tab by clicking 'X' instead of selecting 'Save and Open', a message will prompt:

  • 'There are unsaved changes. Do you want to save your changes?'

Selecting 'Yes', will still create the ticket, even if the Subject field is empty.

The code snippet responsible for setting the Subject as mandatory is not considered when you follow this path, unless you set the Subject as mandatory via Adaptation Mode.

Resolution

This is the current expected system behavior.

A possible option is to check the SAP Cloud for Customer Customer Influence to submit an idea:

Keywords

Subject ; Mandatory ; Ticket ; QC ; Quick Create ; Detail View ; Detailed View ; Ticket Configuration , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions