Symptom
Error "ID mapping for external value XYZ of ERP Product Category missing" is raised while replicating Materials from SAP ERP/S4 to SAP Cloud for Customer.
XYZ Represents example Product Category ID.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Logon to Cloud for Customer.
- Go to Administrator workcenter.
- Open Web Service Message Monitoring under General Settings view.
- Find and select the relevant failed inbound messages for service interface MaterialReplicationInitiatedByExternalIn.
- The error message 'ID mapping for external value XYZ of ERP Product Category missing' is displayed.
Cause
ID mappings are missing for the ProductCategoryID sent in the webservice message.
In Cloud for Customer system, Product Categories are mandatory for Materials, so via replication Product Category ID is also sent from SAP ERP/S4H, however the IDs sent in the webservice messages are external IDs from SAP ERP/S4H.
Cloud for Customer needs to understand which Product Category to be assigned for the corresponding Product, hence ID mapping for this external IDs have to be maintained properly.
Resolution
- Replicate the Product Category from SAP ERP/S4H before you replicate the material, then restart the failed message.
- Or Maintain the ID Mapping for Product category manually with below steps,
- Go to Administrator workcenter.
- Open ID Mapping for Integration view.
- Click Edit ID Mapping for Integration.
- Select Mapping of ERP Product Categories.
- Select relevant System Instance ID.
- Click Go.
- Find and select the relevant Product Category, and maintain ExternalID as XYZ.
- Save.
See Also
Keywords
MATMAS, MATMAS_CFS, MaterialReplicationInitiatedByExternalIn, ProductCategoryID, ERP Product Category missing , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , LO-INT-COD , CRM On Demand Integration , Problem