SAP Knowledge Base Article - Public

2886795 - A Recruiting Email Trigger doesn't have a template set, but it's enabled and is sending emails - Recruiting Management

Symptom

When going to Recruiting Email Triggers, there's/there are trigger (s) where the template is not set, but the trigger is still enabled and active, and the emails are being sent with a content.

Environment

SAP SuccessFactors Recruiting Management

Cause

The template has been disabled in Manage Recruiting Email Templates, but the trigger is still active.

Resolution

The correct workflow to disabling an email template when it's associated to a Recruiting Email Trigger would be:

  1. Disable the Recruiting Email Triggers
  2. Then, go to Manage Recruiting Email Templates, and select the email template
  3. Disable the email template
  4. Go back to Recruiting Email Triggers
  5. Enable the Recruiting Email Trigger once again, selecting a new email template

If the above steps are not completed, that is, if the email template is disabled and the trigger remains active, the system will continue to send the emails because in the backend of the system the trigger stores the email content. So, if the email template has been deactivated and the trigger hasn't, the email content will still be saved by the system to continue to send the emails.

Keywords

recruiting email trigger, triggers, email triggers, email templates, recruiting management, recruiting email templates, manage recruiting email templates, recruiting email triggers without template, no template set, email template disabled. , KBA , LOD-SF-RCM , Recruiting Management , Problem

Product

SAP SuccessFactors Recruiting all versions