SAP Knowledge Base Article - Public

2887171 - Not Possible to Remove Opportunity and Account Creation Rights While Keeping 'Convert To' Options; error: " You are not authorized to perform this action"

Symptom

After removing creation rights for users for Opportunities and Accounts, they can no longer use the 'Convert to' or 'Associate with' options within Leads.

They get the error " You are not authorized to perform this action".

Environment

SAP Cloud for Customer

Reproducing the Issue

Creation Rights for Accounts and Opportunities were disabled via Business role for user ABC.

  1. Login with user ABC.
  2. Go to the Home page quick create button.
  3. Select Account or Opportunity.
  4. The QC opens with the error: " You are not authorized to perform this action".
  5. Go to the Sales work centre.
  6. Go to the Leads view.
  7. Open any Lead with status open.
  8. Click any of the conversion options such as 'Convert to Opportunity'.
  9. You get the error: " You are not authorized to perform this action"

Cause

Converting leads to opportunity or to account is the action of creating an opportunity (or account) - therefore, having both yes and no cannot be achieved logically.

You cannot have 'create' = no but 'convert to' = yes.

The same is true for accounts (cannot have 'create' = no, but 'convert to'/ 'associate with' = yes).

Resolution

If you want users to be able to use the 'Convert to' (ie: Opportunity) options on leads, they will need to have opportunity (and or account) creation rights.

Keywords

Access Rights , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-ACC , Account , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions