SAP Knowledge Base Article - Public

2887304 - Changing The Customer In A Ticket Does Not Update The Registered Product Of The Ticket

Symptom

In a Ticket with a Registered Product, the Customer field can be updated to a different one not associated with the Registered Product. The system does not raise an error.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service work center
  2. Go to Tickets view
  3. Open a Ticket which has a Registered Product
  4. Change the Customer of the Ticket from XYZ to DEF (XYZ and DEF indicates the Customer Name)
  5. System does not raise any error, nor update the Registered Product of the Ticket

Cause

As per the current design, the validation is against the Products object or the Service Reference Object node.

Hence, an error message is raised only for the Registered Product change or addition to something that not associated/owned by the Customer maintained within the Ticket.

Resolution

Changing the Customer in the Ticket will not trigger this validation, this is the expected system behavior as designed.

You need to by create a custom validation using SDK and have that triggered anytime the Customer of the Ticket is changed and cross check this new customer value against the customers maintained within the Registered Product of the Ticket.

Keywords

Registered Product, Customer, Change, Modify, Ticket , KBA , registered product , LOD-CRM-SRP , Service Request Processing , LOD-LE-IBA-IPO , Installation Point , Problem

Product

SAP Cloud for Customer add-ins 2020 ; SAP Cloud for Customer core applications 2011