SAP Knowledge Base Article - Public

2887642 - SMS sent to Candidates - service extranet tool shows multiple SMS sent for each event

Symptom

Service Extranet tool shows multiple SMS sent for a single message to Candidate

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

1. The candidate create an account providing a valid mobile number and the Country

2. select SMS enabled for country: Yes  and Save the profile

     3.png

    3. the action will trigger an SMS notification sent to his mobile phone according to the template define below:

1.png

and the setting in Manage Recruiting Setting:

2.png

Issue:

the customer check the history in service extranet tool noticing that multiple SMS are sent for that message instead of one.

Cause

A possible explanation could be related to some extra character in the SMS template.

For example: Using copy/past from other source can introduce extra characters that generates problem.

As consequence the length of the SMS will be bigger than expected, and this will be equivalent to multiple SMS instead of a single SMS sent.

Resolution

The suggestion will be to exclude this problem will be to delete the entire template and type it manually the body including also the tokens like [[CANDIDATE_FIRST_NAME]].

This method a will avoid any unexpected hidden characters.

Keywords

multiple SMS , candidate SMS , KBA , LOD-SF-RCM-MOB , Mobile Interface, Mobile Apply , Problem

Product

SAP SuccessFactors Recruiting all versions