SAP Knowledge Base Article - Public

2888127 - Error Message "Enter a Customer" When Creating a New Registered Product

Symptom

Error messages "Enter a Customer" and "Save Failed" are thrown when trying to create a new registered product.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Installed Base work center.
  2. Go to the Registered Products view.
  3. Click in Create.
  4. Maintain fields but field Customer.
  5. Click in Save.
  6. Error messages "Enter a Customer" and "Save Failed" are thrown.

Cause

Currently the Customer field is mandatory when creating new Registered Products.

Resolution

This is the standard behavior of the system.

If you believe the Customer field should not be mandatory when creating a new Registered Product, you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.

You can find more details about the services offered by Cloud Service Center. You can contact Cloud Service Center as follows:
1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
2. If you are a customer: please use the little blue box “Contact Us” shown on the very right hand side of SAP Application Development site, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page.
Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
An alternative option may be to check the SAP Customer Influencer Site to submit an idea.

Keywords

KBA , AP-IBA-IPO , Installation Point , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions