SAP Knowledge Base Article - Public

2889039 - Integration Center - Filtering on 'null' values

Symptom

How to filter on 'null' values when building/using an integration in Integration Center?

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

When filtering on 'null' values in Integration Center, unexpected results may be received.

Cause

The 'null' (empty) value is considered separately from any other value in a field.

Resolution

This is the behaviour of 'null' when used to filter the results:

  1. Using 'is equal to null' as a filter will return all the records with 'null' values for the selected property
  2. Using 'is not equal to null' as a filter will return all the records with a recorded value for the selected property
  3. Using 'is not equal to X' will return all the values not equal to X BUT not the 'null' results. This basically selects all the records with a non-null value not equal to X. To select all the records not equal to X, you would need to use a filter like this:
     Filter example.png
    The first statement will select all non-null values not equal to 'Complete', the second statement will select all 'null' values.

Keywords

Integration Center, filter, null , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , How To

Product

SAP SuccessFactors Recruiting all versions