SAP Knowledge Base Article - Public

2889245 - Picklist Postal Code Fails Address Deep Validations in Employee Central

Symptom

Address validation is failing when the Postal Code is a Picklist Value

Environment

  SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Make Sure Address Validation is enabled
  2. Configure instance to populate postal codes based on a picklist value
  3. Enter Postal Code > Error is thrown 

Cause

  • This product feature is working as designed
  • Address Validation currently does not support picklist as values
  • The validation reads in the option ID instead of the labels of the picklist

Resolution

  • SAP Cloud Product Support apologizes for any inconvenience this conclusion may cause
  • If the desired business functionality is important to your organization, please consider creating an Enhancement Request

See Also

KB article 2090228 - How to Submit Enhancement Requests for SAP SuccessFactors Products

Keywords

SF, Success Factors, EC, pick list, isn't working, zip code , KBA , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , Problem

Product

SAP SuccessFactors Employee Central all versions