SAP Knowledge Base Article - Public

2889293 - Account Group changes is not permitted for Business Partner with CPD Account Group (One Time Customers) in SAP S/4HANA Cloud Public Edition

Symptom

“Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.“

  • Error "Switch to account group &1 not possible" is raised when trying to change CPD account group to another account group (Customer or Supplier) for a Business Partner.
  • The error "Customer ******* is a one-time customer. No change of account group defined" is encountered when there is an attempt to change the account group. 

CPD.PNG

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open a Business Partner with Grouping CPD.
  2. Click on Edit.
  3. Change the account group.
  4. Click on save.
  5. The system raises the error.

Cause

The CPD Customer Account group is a "One-Time" account group, so it is not possible to change to another account group. This is hardcoded into the system.

Resolution

  1. Archive and then delete the "One-Time" Customer or Supplier Business Partner. 
  2. One-time Customer and Suppliers need to be marked in the Manage Archiving Allow List app to allow archiving and deletion.
  3. Re-create the Customer Business Partner in the desired new account group.

See Also

Keywords

S4_PC, S4_1C, SAP S/4HANA Cloud Public Edition, switch, account, group, CPD, one-time, customer, supplier, CVIV_UI178, CVIV_UI 178, F2 688, F2688, LO-MD-BP, S4HC, S/4HANA, S4_PC , KBA , LO-MD-BP , Business Partners , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions