SAP Knowledge Base Article - Public

2889515 - Territory in Sales Document is not pulled from the Account: Multiple Territories in Account

Symptom

You have scoped to automatically update Open Sales Documents with the Account Territory but this is not working for Sales Order ABC (ABC represents the name of a Sales Order) in our example.

Environment

SAP Sales Cloud

Reproducing the Issue

  1. Go to the Sales workcenter.
  2. Go to the Sales Orders view.
  3. Open Sales Order ABC.
  4. Check the Territory and find it empty.

You possibly also see an error "Please select a territory. Account is assigned to multiple territories".

Cause

The Account in the Sales Order ABC has multiple Territories assigned.

Resolution

In case multiple territories are identified, the system does NOT take one arbitrarily but leaves it empty and issues a warning message: "Please select a territory. Account is assigned to multiple territories". Please select the Territory manually.

However, in case you have turned off this message in BC Finetuning for the respective BO -> Message Severity Configuration, this warning does not appear in the UI. When users are confused by not getting a territory, it is better to remove the "Suppress Message" flag in BC Finetuning.

Keywords

territory, multiple, Please select a territory, Account is assigned to multiple territories, sales order, sales quote, opportunity , KBA , LOD-CRM-TM , Territory Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions