SAP Knowledge Base Article - Public

2890147 - Cannot Select User in Operator/Operator Team field in a Job Requisition - Recruiting Management

Symptom

When adding an User to the Job Requisition Operator/Operator Team field, the user cannot be found.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. In Recruiting, go to a Job Requisition
  2. In the Operator/Operator Team field, try to search for the user
  3. The user won't be found

 2020-02-07_11-01-55.png

Cause

Possible causes for this scenario:

  • The Operator/Operator Team field is linked with a Recruiting Group. In this case, it is only possible to choose a member from the group, but the user is not a member of the group.
  • There is an issue with the people pools or categories configuration in the Recruiting Group, which leads to incorrect membership.
  • A wrong Recruiting Group is linked to the Operator/Operator Team field inside the Job Requisition template.

Resolution

1. Operator / Operator Team Field

To perform changes in the Job Requistion template, you must have access to Manage Templates or engage your Partner/Implementation Team.

Refer to KB article 2728359 for instructions on how to check the Recruiting Group linked with the Operator/Operator Team Field.

Verify the Group Name to ensure it matches the group name configured in Manage Recruiting Groups. If the group name is incorrect, enter the correct group name.

Job Req_Operator_Recruiting Group.png

A sample of Job Requisition XML template:

2020-02-07_11-06-32.png

 

2. Recruiting Group:

  1. Go to Admin Center > Manage Recruiting Groups
  2. Find the respective Recruiting Group
  3. Click on Edit
  4. Add the user
  5. Verify the Group Membership by clicking on the Update button
  6. Save the changes

Verify the Group Name to ensure it matches the group name configured in the Job Requisition template. Also, ensure that there are no leading or trailing spaces.

If users are being added through multiple People Pools or Categories, ensure that there are no conflicting criteria. Refer to KB article 3410433 which addresses common issues.

Note: Confirm if the correct User is being added. If the wrong User is added, the user will have access to Recruiting and all the respective Job Requisitions that are attached to this Recruiting Group.

2020-02-07_11-05-45.png

For more information about Recruting Groups, refer to KB article 2291548 - Working with Recruiting Groups in SuccessFactors Recruiting

After implementing the changes, you should be able to select the User in the field:

2020-02-07_11-03-46.png

See Also

  • KB article 2291548 - Working with Recruiting Groups in SuccessFactors Recruiting
  • KB article 2728359 - How to set a Recruiting Group via Manage Templates
  • KB article 2725464 - When Selecting a User for the Route Map, Options are Not Reflecting Those Set in Recruiting Groups
  • KB article 3410433 - Recruiting group displays zero membership even though users have been added - Recruiting Management

Keywords

sf, success factors, RCM, team, can't add user, can't find operator, missing user, cannot add role, recruiting group, team , KBA , LOD-SF-RCM-JOB , Job Postings & Requisitions , Problem

Product

SAP SuccessFactors Recruiting all versions