Symptom
An instance refresh was done, and the candidates' email addresses were updated to dummy@sap.com. It was requested to revert the candidate emails' to what it was before the refresh, but when searching for candidates in Keyword and Item Search, it is showing the wrong email address, it is showing the dummy@sap.com email.
Environment
SAP SuccessFactors Recruiting Management
Cause
This search is uses the Solr Index to refer to when it's showing data.
Resolution
When an instance refresh is done, all the users' and candidates' email addresses are changed to dummy@sap.com so they don't receive any unwanted or invalid emails from the instance. What happens after the refresh is performed a Solr Index in the instance so the information is also refreshed in there.
As soon as the emails were changed back to the previous information by Operations, through a script, the Solr Index didn't occur again (since it has to be triggered), which caused the search to still display the dummy@sap.com email address. Running a re-index should resolve the issue, to refresh the data in the Solr Index search.
Keywords
dummy@sap.com, email, address, index, re, index, solr, instance, refresh. , KBA , LOD-SF-RCM-CAP , Candidate Profiles , Problem