Symptom
Candidates are not able to delete their attachments like Resume and Cover Letter from their Application Profiles
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Log in the External Career site
- Open an Application from a Job you had applied
- See that there won't be a option to delete the attachment
Cause
This is an expected behavior. In Single Stage environment, candidates can only edit the Application Profile data at the initial application. The attachments will become read-only later on. For more information about Single Stage configuration, refer to the KBA 2472497 - Single-Stage, Late Stage and Multi-Stage Application - Recruiting Management.
Resolution
To grant the ability to the candidates to edit/remove the attachments in any stage, you must have Multi Stage environment enabled. Refer to the following KBA for more information about Multi Stage: 2780650 - How to Enable Multi-Stage Application Environment - Recruiting Management.
See Also
2472497 - Single-Stage, Late Stage and Multi-Stage Application - Recruiting Management
2780650 - How to Enable Multi-Stage Application Environment - Recruiting Management
Keywords
Edit, Remove, Delete, Change, Attachment, Resume, Cover Letter , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , LOD-SF-RCM-JOB , Job Postings & Requisitions , Problem