Symptom
A customer has a business rule that updates a field in a child element in the dependents portlet (Child element can be any portlet like Home Address, Personal Information, national ID, and Global information) however the same business rule does not work when UPDATING/Modifying the record.
The rule only works on the first time you insert the record.
As an example:
I have a business rule that sets the Initials (Initial is a field under Personal Information) of a dependent to TEST.
I went to an employee and added a new dependent with effective date 02/01/2020.
As I save the portlet you will see that the business rule worked. The initials has been set to "TEST"
Now to reproduce the issue, do the same action but this time (the transaction will become an edit/update) since we are inserting the record on the same date ( in this example Feb 1 2020)
As a result you will see that the Initials test did not transform to "TEST" as per the rule.
Environment
SuccessFactors Employee Central Dependents Management.
Cause
This is a current system limitation which is tracked under ECT-129976, Our engineering team is planning to enhance our product to support this scenario, kindly monitor this KBA as we will update this KBA once we have a fix date for this.
See Also
Keywords
BusinessRulenotWorking, Rule, Dependents. , KBA , LOD-SF-EC-DPD , Dependents Management , Problem