Symptom
The Survey Aggregated Results is appearing blank on the survey summary despite your visit having a score.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: create a survey 123 with a functioning score and assign it to an activity plan & routing rule for it to be available in a visit ABC (123 represents the survey and ABC represents our visit name).
- Go to the Visits work centre view.
- Open ABC.
- Go to the Surveys facet.
- Add the survey 123.
- Answer 123 and click Submit.
- Actions > Generate Summary.
- Go to the Surveys view.
- Go to the Related Attachments view.
- Open the newly created pdf.
Result: The Appendix shows up empty.
Cause
Since this is a Checklist type Survey, the Aggregate result will show up only at the Section level.
Resolution
The Survey has to be designed with different Sections and questions under each section. Then, the aggregation will show up for each Section.
Note: The table with aggregate results will not show up under "Survey Questions Aggregate Result:". Rather, it will show up under each Section directly as shown in the screenshot. This is the designed behaviour.
Keywords
Empty, Summary , KBA , LOD-LE-SUR-EXE , Survey execution = runtime , LOD-CRM-ACT-VST , Visit Planning , How To