Symptom
When you import Visits using Data Workbench, system throws error.
or
You have Accounts who have changed from an old Account ID to a new Account ID. Therefore, the respective Visits need to be transferred to new Account ID as they are no longer associated with old Account ID. Upon trying to update the Account ID in Visits using Data Workbench, you see the error.
Change of party with role Account is rejected because read-only
Environment
SAP Cloud for Customer
Reproducing the Issue
When importing new Visits:
- Go to Data Workbench workcenter
- Go to Import view
- Select the radio button for Individual Object
- Go to Import tab
- Go to Standard Object tab
- Search for the Data Workbench object Visit
- Select the button Download Comma Separated Values (.csv) to download the template
- Fill the required data in the file
- Select Browse and go to the file location
- Select the file and select Open
- Select Upload
- System throws the mentioned error
To export existing Visits:
- Go to Data Workbench workcenter
- Go to Export tab
- In the Search field, select the Data Workbench object Visit
- Choose appropriate filters if required
- Select Next
- Export Data
- Go to the Monitor tab
- Download the exported file
Perform the Update of the Visits:
- Modify the data for the required fields in the file
- Save the file
- Go to Data Workbench workcenter
- Go to the Import tab
- Select the radio button Individual Objects
- Go to Update tab
- Select the select the Data Workbench object Visit
- Select Next and Browse for the file
- Select Upload
- Choose Next to review the summary of your selection
- Select Import
- Go to Monitor view to check the status of your import
The records in the file have the Processing Error.
Cause
The error could be due to the below reasons:
- External Key used in the .CSV file is already used in another .CSV file to import records
- This is expected behavior and as per design. Even from UI we cannot change Account ID for the existing Visits which got Canceled and also Surveys associated.
Resolution
If the error occurs while importing new Visits, change the External key and try the import again to overcome the error message.
If the error occurs while changing the Account ID of the existing Visits, you may note the below points:
- When there is no Survey in Visit, and Visit status is Open /Completed, it is possible to change the Account ID of Visit.
- When there is no Survey in Visit, and Visit status Canceled, it is not possible to change the Account ID of Visit.
- When there is/are Surveys with the Visit, it is not possible to change the Account ID of Visit. That is, if Survey status is Open /Completed and Visit status is Open /Completed, it is not possible to change the Account ID of Visit.
Keywords
Survey, Visit, Account, Data Workbench , KBA , survey , data workbench , visit , account , external key , LOD-CRM-INT-DWB , Data Workbench , Problem