SAP Knowledge Base Article - Public

2891648 - How to Query The Survey Result Facet

Symptom

The queries on the Survey Result facet are by BO.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work centre. 
  2. Go to the Accounts view.
  3. Open any account for which surveys have previously been submitted.
  4. Go to the Survey Results facet.

The surveys cannot be queried all at once (there is no 'All' filter).

Cause

To query the surveys, select the relevant BO, for example Visits. All surveys submitted for the selected BO will be displayed.

Resolution

This is expected behaviour by system design.

Keywords

query missing, all , KBA , AP-RC-UIF , C4C UI Framework , LOD-CRM-ACC , Account , LOD-LE-SUR-EXE , Survey execution = runtime , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions