Symptom
You are going to create new service confirmation from a sales order, the line is successfully copied into the new confirmation. But when you click Save button to save the document, system shows error: Save Failed.
You want to know what is the exact reason for the failure of save.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Sales Orders view.
- Find the sales order ABC and click Edit button, the order is In Process status. (ABC represents the ID of the sales order).
- Click View All button and go to Items tab, select line# for example 70, this line is In Process status.
- Click Submit - Confirm Service Execution button, system opens a new service confirmation and the line 70 is copied.
- Click Save button to save the new Service Confirmation, system shows error: Save Failed.
There is no more error displayed, you do not know the real reason of the failure.
Cause
Even though the order status is In Process, there is at least one line added into the sales order lately has not yet released.You can see the Release Order option is enabled. Due to the status of the order line, it is not possible to save the follow up service confirmation.
In this case, the line 80 was added newly, select the line, you can see the release status is Not Released.
Anther case may bring such confusion: If a sales order with 2 items created with status In Preparation, later on it has one of the item cancelled, then the sales order goes into In Process, the user may not realize that the sales order was not released due to the status(this has been standard behavior).
Resolution
You need to release the order firstly, then perform the new service confirmation creation.
- Edit the sales order ABC.
- Select Submit - Release Order button.
- Then, click Submit - Confirm Service Confirmation button to create new service confirmation document.
You should be able to save the new service confirmation.
Keywords
Service Confirmation; Save Failed; MSGID CL_CDA_STATUS; , KBA , SRD-CRM-SEO , Service Orders , SRD-CRM-SEM , Service Management , Problem