Symptom
While User initiate Onboarding for Candidate and they receive below error in the BPE Process.
"User Name already Exists. Please change user Name and restart"
Environment
Successfactors Onboarding 2.0
Reproducing the Issue
Login to Instance and Proxy as Hiring Manager. Click on BPE Process tile in the Home page and you see below error message displayed.
"User Name already Exists. Please change user Name and restart"
Cause
Using same Email ID as User ID for the Candidate while Initiating the Onboarding for the candidate
Resolution
The username is the email id provided by the candidate in the external career site. The user might have tried to initiate onboarding for the same candidate again.
So effectively there can be only open Onboarding process for a candidate in RCM.
In order to initiate again for the same candidate, the previous onboarding has to be cancelled from the dashboard.
Keywords
BPE Process, ONB 2.0 , KBA , LOD-SF-OBX-BPE , BPE Process Flow , Problem