SAP Knowledge Base Article - Public

2892313 - Mobile sessions are not getting released in SAP Business Intelligence Platform 4.x

Symptom

  • Multiple sessions are created for the same user with every login in Mobile application.
  • Sessions for SAP BI Mobile App (SAP Businessobjects Mobile) are not getting cleared under CMC>Session after the App is killed in device.

Environment

  • SAP BusinessObjects Business Intelligence Platform (BI) 4.x
  • SAP BI Mobile App 6.x
  • iOS, Android

Reproducing the Issue

  1. Login to SAP BI Mobile Application.
  2. Minimize the Application.
  3. Kill the SAP BI Mobile Application.
    Observation: Session does not get cleared under CMC -> Sessions for a long time.
  4. Login again to SAP BI Mobile Application using the same user.
    Observation: a new SAP Businessobjects Mobile session is seen added under CMC -> Sessions with the same user.

Cause

  • The behavior is by design.

Resolution

In order to avoid consumption of multiple sessions for the same user, follow the below approach:
- Log out from the SAP BI Mobile Application, instead of minimizing or killing the app manually.
This will ensure that:
- the said unused session gets cleared under CMC almost immediately.
- prevent situations wherein new users are unable to login because of stale/unused sections.

Keywords

stale session,Business Objects mobile session, session timeout, sessions not released, mobile, mobi , KBA , MOB-APP-BI-SRV , Mobile BI Server , Problem

Product

SAP BusinessObjects Xcelsius Enterprise 2008