Symptom
You received an error <faultcode>soap:MustUnderstand</faultcode> headers while replicating the master Data from C4C to SAP FSM
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Administrator Work Center
- Navigate to General Settings
- Open Web Service message monitoring under System administration
- Find web service message in Failed status
Cause
Communication System is not configured as expected
Resolution
- Go to Administrator Work Center
- Navigate to General Settings
- Open Communication Systems under Integration
- Open the communication system which is created for C4C-FSM integration
- Make sure that under System Instances, the System Instance ID must be the same as the company ID created in the SAP Field Service Management and Preferred Application Protocol should be "5 - Web Service"
Keywords
soap:MustUnderstand, FSM, C4C, system Instance ID, 503 error , KBA , LOD-CRM-SRP-CSI , Integration of service ticket with Core systems , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2002