SAP Knowledge Base Article - Public

2893556 - Check service error after Tenant Copy: A technical error occurred (Message communication profile has no RBAM role): /DOC/MBCA 046

Symptom

“Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.“

When an order is created via webservice you receive an error -

“Authorization role missing for service "ServiceInterface http://sap.com/xi/A1S/Global ServiceInterfaceName <default> <default>", operation "Operation http://sap.com/xi/A1S/Global MaintainBundle" (UTC timestamp 20240301090619; Transaction ID 390B35FD2BD61EDEB5F55EEC72799B1F)”

Check the service from the communication arrangement, you will receive the following error:

"A techincal error occurred (Message communication profile has no RBAM role): /DOC/MBCA 046. Report an incident."

Environment

  • SAP Cloud Application Studio
  • SAP Cloud for Customer
  • SAP Business ByDesign

Reproducing the Issue

Pre requisites:

  1. A tenant copy has been completed.
  2. You have a communication arrangement based on a custom web service created via the Cloud Applications Studio.

Steps to reproduce:

  1. Administration and User Management.
  2. Communication Arrangements.
  3. Open the Communication Arrangement.
  4. Technical data > Edit advanced settings > check service.

Error: A technical error occurred (Message communication profile has no RBAM role): /DOC/MBCA 046

CheckServiceError.png

Cause

1.The effected service interface in the .csd file has a different process component from the one present in the .csd file. This error occurs after the Tenant Copy and is an expected system limitation.

2.PC Interactions present in the MCPs are not actually created(not present) in the system which is causing the RBAM issue

Resolution

1.Activate the .csd file on the souce tenant, deploy the solution to the target tenant and create a new communication arrangement on the target tenant.

2.Recreate the communication scenario and the arrangement

  • Delete the communication arrangement 
  • Delete the communication scenario 
  • Recreate the communication scenario 
  • Recreate the communication arrangement for this communication scenario 

Keywords

profile, PDI, SDK, scenario, technical , KBA , AP-RC-BDS-WS , ByDesign Studio Web Services , AP-RC-CEC-B2B , ByD On-Demand Cloud-Process Integration B2B , How To

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions