SAP Knowledge Base Article - Public

2893833 - Error Message "Rule set too large/complex to compute" Is Shown Even for Simple Rules

Symptom

You are working with business rules in your administration settings (for example: Ticket Routing Rules by Employee) and when trying to activate the rule set you see error messages:

  • Rule set too large/complex to compute

  • Please reduce/simplify rule set and try again

Environment

SAP Cloud for Customer

Reproducing the Issue

The issue is reproducible with different BRF+ Rule Sets in the system, we will use Ticket Routing Rules by Employee as example.

  1. Go to the Administrator work center.
  2. Select the Service and Social view.
  3. Under Work Distribution, select Ticket Routing Rules by Employee.
  4. Click on Actions > Activate Rules.

Two error messages are shown:

  • Rule set too large/complex to compute

  • Please reduce/simplify rule set and try again

However, the rule set is very simple.

Cause

There is a syntax issue with the way the cells have been maintained.

Resolution

If you have more than 20 rules, please use the download option to export the previous activated consistent rule set and make the necessary changes to this file. The updated file can be uploaded back into the system as a new version.

A very common syntax issue with the rule set is how multiple values are added to a field. Usually, there is an extra space added. The correct way to add multiple values to a field is: 123; 456 (123 and 456 represent ID's of the Object you are maintaining in the rule set).

If you have over 1000 total cells in the rule set, please also check KBA in "See Also" section.

See Also

KBA 3267010 - Rules Cannot be Uploaded, Error: "Rule set too large/complex to compute | Please reduce/simplify rule set and try again"

Keywords

BRF, Rules Framework, Party Rules, Ticket Routing Rules, Territory Rules, Maintain Item Processing Codes, Maintain Determination, Team Rules, Ticket Rules, Quote, ranges, syntax , KBA , LOD-CRM-BRF , C4C BRF Configuration , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions