Symptom
You are working with Ticket Routing Rules by Employee and when trying to activate the rule set you see error messages:
-
Rule set too large/complex to compute;
-
Please reduce/simplify rule set and try again.
Environment
SAP Cloud for Customer
Reproducing the Issue
The issue is reproducible with different BRF+ Rule Sets in the system, we will use Ticket Routing Rules by Employee as example.
- Go to the Administrator work center.
- Select the Service and Social view.
- Under Work Distribution, select Ticket Routing Rules by Employee.
- Click on Actions > Activate Rules.
Two error messages are shown:
-
Rule set too large/complex to compute;
-
Please reduce/simplify rule set and try again.
However, the rule set is very simple.
Cause
There is an issue with the way the columns have been maintained.
Resolution
A very common issue with the rule set is how multiple values are added to a field. Usually, there is an extra space added.
The correct way to add multiple values to a field is:
123; 456 (123 and 456 represent ID's of the Object you are maintaining in the rule set).
See Also
KBA 3267010 - Rules Cannot be Uploaded, Error: "Rule set too large/complex to compute | Please reduce/simplify rule set and try again"
Keywords
BRF Rules ; Party Rules ; Ticket Routing Rules ; Territory Rules ; Maintain Item Processing Codes ; Maintain Determination ; Team Rules ; Ticket Rules ; Quote , KBA , LOD-CRM-SRP , Service Request Processing , How To