SAP Knowledge Base Article - Public

2893968 - Error 'No business system ID was provided' when SOAP API SalesOrderBulkRequest_In is called - SAP S/4HANA Cloud Public Edition

Symptom

After calling an inbound service of SOAP API SalesOrderBulkRequest_In, a response 'HTTP/1.1 202 Accepted' is displayed. In Fiori App 'Message Dashboard', in regard of this API request, an error saying 'No business system ID was provided' is found.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Call API service of SalesOrderBulkRequest_In from SOAP UI to create a sales order on SAP S/4HANA Cloud Public Edition system;
  2. Get a response saying 'HTTP/1.1 202 Accepted';
  3. In Fiori App 'Message Dashboard' with Namespace: /SDSLS, an error 'No business system ID was provided' is displayed for this API request.

Cause

The payload of this API request is incomplete and the field <SenderBusinessSystemID> is missing.

Resolution

To send this service using the example request provided on help portal as the payload.
As one of the fields from message header, field 'SenderBusinessSystemID' indicates the ID of the external business system that sends this message, and also it's used to determine the receiver of the sales order confirmation message. So add this field if it's missing and re-try this API request.

See Also

Fiori App <Message Dashboard>
Sales Order (A2A) Overview
Business Documentation of API SALESORDERBULKREQUEST_IN
Example Request of SalesOrderBulkRequest_In

Keywords

SalesOrderBulkRequest_In, 015(SOA_SD), SRT_UTIL, SRT_MONI, Message Dashboard, SOAP API, SAP_COM_0288, HTTP/1.1 202 Accepted , KBA , SD-SLS-API , API , SD-SLS-API-2CL , API (Public Cloud) , Problem

Product

SAP S/4HANA Cloud 2002