SAP Knowledge Base Article - Public

2894061 - [Onboarding] Process not created due to incorrect EC Picklist Association - Onboarding

Symptom

This article provides information on what could be causing the process not to be created in OBX due to incorrect EC picklist association.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

"Initiate Onboarding" is selected in Recruiting Management for a candidate but the Onboarding Process is not created.

Cause

EC Picklists in Picklist Centre have been modified and the required External Code is missing from the associated lists value.

Resolution

For the EC Picklists that are associated with Onboarding, ecEmailType, ecPhoneType & ecMaritalStatus, we must use the standard system generated External Codes.

If the associated External Codes are modified this will affect the creation of the process for Onboarding.

Any Modifications to the External Codes are not supported as the standard configuration must be adhered to.

To ensure the correct External Codes are maintained please follow the below steps and ensure the correct codes are maintained.

  1. Navigate to Picklist Centre.
  2. Review the following EC Picklists:
    1. ecEmailType
    2. ecPhoneType
    3. ecMaritalStatus
  3. Ensure that the External Codes are set as follows for their respective picklists:
    1. ecEmailType
      ecEmailType.png
    2. ecPhoneType
      ecPhoneType.png
    3. ecMaritalStatus
      ecMaritalStatus.png
      ecMaritalStatus2.png

Keywords

EC Picklist, Onboarding, ecEmailType, ecPhoneType, ecMaritalStatus, Process, External Code , KBA , LOD-SF-OBX-EC , Integration EC - MPH, Hire , Problem

Product

SAP SuccessFactors Onboarding all versions