Symptom
- When using IDocs for integration scenario, all of the IDocs get stuck in status 64 (In Process).
- Asynchronous documents not posted using DEBMAS IDocs.
- When using asynchronous method to create customers using DEBMAS and post financial documents using Journal Entry(SOAP), the content is visible in the app "Message Dashboard" but these messages are in the same status(In Process) for a long time.
Environment
SAP S/4HANA CLOUD
Cause
Mandatory field is not passed.
Resolution
Field KUNNR is mandatory in IDoc processing. Kindly pass the field KUNNR in E1KNA1M segment in order for IDocs to get processed.
See Also
The process can work with internal number ranges but the numbers under which the customers or vendors are created should be determined in advance, passed to the KUNNR field. KUNNR remains mandatory irrespective of the number range settings. Please refer to SAP Notes 371850 and 2394173 for more information. Also the BP number which is created by the IDoc will not be known, hence the Customer and BP number will differ in this case.
Keywords
S/4HANA Cloud, SAP, BP, business, partner, Idocs, IDOC, stuck, hanging, customer, supplier, vendor, kunnr, DEBMAS, number, range, communication, scenario, integration, inbound, outbound , KBA , LO-MD-BP , Business Partners , Problem