SAP Knowledge Base Article - Public

2894762 - Customer Return is Inconsistent - Sales Order Reference Not Valid

Symptom

You received an error message when trying to assign a Sales Order as reference to a Return.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Select the Returns view.
  3. Search for the Return ID: ABC (ABC represents the ID of the Return).
  4. Press Go button.
  5. Select the Return and click the Edit button.
  6. Error appears: Sales Order Reference with ID XYZ-10 not valid (XYZ-10 represents the ID of the Sales Order and Item).

Cause

The reason why the system is not able to assign the Sales Order XYZ to the Customer Return ABC, is because the Sales Order items have been canceled.

Resolution

This is the expected system behavior.

Remove the reason for the rejection maintained in the Sales Order and assign the reference to the Customer Return.

See Also

1505322 - Customer Return is Inconsistent - Order Reference Not valid

Keywords

Customer Return, Sales Order, Reference, Not Valid , KBA , AP-CRP-CR , Customer Return , How To

Product

SAP Business ByDesign all versions