Symptom
When accessing a dashboard, you can see 'XYZ Filter Cannot Be Applied As You Are Not Authorized For The Lead Report' error message.
Environment
SAP Cloud for Customer
Reproducing the Issue
Case 1:
- Go to Business Analytics work center.
- Go to Design Dashboards work center view.
- Search for a dashboard.
- Open it.
- You can see the error message.
Case 2:
- Go to Analysis work center.
- Go to Dashboard work center view.
- Open the specific dashboard.
- You can see the error message.
Error Message: XYZ Filter Cannot Be Applied As You Are Not Authorized For The Lead Report
Cause
Case 1:
It occurs when the characteristic used as a filter in the dashboard was added to the report via 'Add Fields' instead of via 'Report Wizard'. You can check it following these steps:
- Go to Business Analytics work center.
- Go to Design Reports work center view.
- Open the report used in the dashboard.
- Open and run it.
- Go to View > Add Fields.
- You can see those characteristics were added via Add Fields.
Please note that a field was added via 'Report Wizard', it will be grayed out in the 'Add Fields'. If the field was not added via 'Report Wizard' it will not be grayed out and you can edit it via 'Add Fields'.
Case 2:
It occurs when an end user has personalized the report view used in dashboard and enabled the hierarchy for one of the field which was added via Add Fields (rather than adding the field via report wizard).
Resolution
In order to adjust the report and avoid such cases, you can follow these steps:
Case 1:
- Go to Business Analytics work center.
- Go to Design Reports work center view.
- Open the report used in the dashboard.
- Click to Edit.
- Go to Step 4.
- Search the field used a filter.
- Change from 'No Selection' to 'Using Variable'.
- Save it.
Case 2:
- Go to Analysis work center.
- Go to Reports work center view.
- Search for the report with the view which has been used in dashboard (or the report where you have done the personalization).
- Open the report.
- Go to View tab and click on Add Fields.
- Search for field where hierarchy has been enabled.
- Check if hierarchy enabled field was added via Report Wizard (by Admin/Key User).
- If not, then disable the hierarchy (uncheck the box for hierarchy) for that field.
- Save the report view (overwrite it, do not save a new view).
Then, the dashboard should not display those messages warning messages.
Keywords
filter cannot be applied as you are not authorized for the lead report, filter, dashboard, warning message, characteristic filter cannot be applied, hierarchy, end user, personalize , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , LOD-CRM-ANA-DAS , Interactive Dashboard , How To