Symptom
You observe that for a Completed Ticket, most of the fields are read only, but the Partner field is still editable.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service workcenter
- Go to Tickets view
- Open Ticket 123(where 123 is the Ticket ID)in Completed status
- Go to the Overview facet
- Click on the Edit button and go to edit mode
- The Partner field is not read only
Cause
When the Ticket status is Completed, some fields are still allowed to be editable from the UI (such as the ones that do not break the business process).
Resolution
This is an expected system behavior. As a workaround, you can set a visibility rule using key-user adaptation and set the 'Read-only' property of those fields, when the Ticket is in 'Completed' status
See Also
Keywords
partner, edit, ticket, completed, closed , KBA , ticket , completed , closed , edit , read only , partner , grayed out , LOD-CRM-SRP , Service Request Processing , Problem